X
تبلیغات
وکیل جرایم سایبری

انجمن مدیران و راهبران شبکه

Network Managers and Administrators

نحوه راه اندازی اولیه و تخصیص آدرس IP به VMware vCenter Appliance یا VCSA

با عرض سلام و شب بخیر مجدد خدمت همه دوستان خود جغد پندار عزیز  لازم از در این ساعت های اولیه بامداد روز سه شنبه 24 مرداد 1396 به خدمتتون عرض کنم که برای راه اندازی اولیه VCSA و تخصیص آدرس IP به این شاه نرم افزار مدیریت محیط مجازی شرکت VMWare کافی است مراحل زیر را انجام دهید:


  1. از داخل  Vsphere Client یک کنسول به VCSA باز کنید.
  2. با نام کاربری root  و کلمه عبور پیش فرض vmware به سیستم ورود کنید.
  3. دستورمقابل را اجرا کنید تا منوی تنظیم آدرس شبکه باز شود: /opt/vmware/share/vami/vami_config_net
  4. خوب خوب خوب   حالا در منوی باز شده امکان تنظیم پارامتر های شبکه از قبیل IP Address، Hostname، DNS و Default gateway و Proxy Server فراهم می شود.

شب بخیر.

تاریخ ارسال: سه‌شنبه 24 مرداد‌ماه سال 1396 ساعت 01:49 | نویسنده: Iman Mojtahedin Yazdi 0 نظر

گزیده ای از برخی دستورات خط فرمان (cmd) پرکاربرد در Microsoft Windows Server 2016 و VMware ESX


CMD :

==================

- servermanager.exe

- sconfig.exe

- dcdiag /fix

- nltest /dcregdns


vMware ESXi:

=================

- vmware -l

- vmware -v

- esxcli vm process list

- vim-cmd vmsvc/getallvms

- vim-cmd vmsvc/power.getstate <vmid>

- vim-cmd vmsvc/power.on  <vmid>


در حال ویرایش ...

تاریخ ارسال: سه‌شنبه 8 فروردین‌ماه سال 1396 ساعت 13:14 | نویسنده: Iman Mojtahedin Yazdi 0 نظر

Resetting an expired password in vCenter Single Sign-On

نحوه ریست نمودن کلمه عبور vCenter SSO

Resetting an expired password in vCenter Single Sign-On 

Details

  • vCenter Single Sign-On account (SSO) passwords expire after 365 days, including the password for admin@system-domain.
  • In vSphere 5.1, you see this error on a login attempt with an expired password:

    Web Client: "provided credentials are not valid"
  • In the vsphere_client_virgo.log, you see the error:

    SOAP fault javax.xml.ws.soap.SOAPFaultException: Authentication failed

Solution

vCenter Single Sign-On administrator users can change expired passwords for System-Domain users. Request that an administrator resets your password.

If you are a vCenter Single Sign-On administrator user, use the ssopass command-line tool to reset the password.

On the Windows host running vCenter Single Sign-On:
  1. Open an elevated command prompt and run the command:

    SET JAVA_HOME=C:\Program Files\VMware\Infrastructure\jre

    Note: This is the default path of the JRE folder for vCenter Server 5.1. If vCenter Server has been installed in a custom location, change command accordingly.
  2. Navigate to the ssolscli directory

    c:\>cd C:\Program Files\VMware\Infrastructure\SSOServer\ssolscli
  3. Run the following command:

    ssopass -d https://FQDN_of_SSO_server:7444/lookupservice/sdk username
  4. Type your current password, even if it is expired.
  5. Type the new password, and then type it again to confirm. 

From the vCenter Server Appliance (VCSA):
  1. Log in to the vCenter Server Appliance as root.

    Note: The default password is vmware.
  2. Navigate to this directory:

    /usr/lib/vmware-sso/bin
  3. Run this command:

    ./ssopass -d https://FQDN_of_SSO_server:7444/lookupservice/sdk username
  4. Type the current password for the user, even if it is expired.
  5. Type the new password, and then type it again to confirm.
تاریخ ارسال: چهارشنبه 13 اسفند‌ماه سال 1393 ساعت 12:29 | نویسنده: Iman Mojtahedin Yazdi 0 نظر

نحوه بروز رسانی VMWare ESXi

VMware Update


شما ابتدا SSH رو روی Host به صورت Enable در میارید.

فایل مورد نظر رو به سرورتون منتقل میکنید.(برای سادگی کار از WinScp استفاده کنید و یا خود کنسول Vmware).

فایل مورد نظر رو تو شاخه اصلی دیتا استور کپی کنید.( /[vmfs/volumes/[DATA-STORE]/)

بعد با نرم افزاری مثل Putty با دستور زیر عملیات آپدیت رو انجام بدید:

esxcli software vib update  -d /vmfs/volumes/[DATA-STORE]/[PATCH_FILE].zip

اگر موقع آپدیت به مشکلی مبنی بر آپدیت نشدن به خاطر استفاده از منابع شدید لطفا دستور زیر رو وارد کنید:

esxcli software vib install  -d /vmfs/volumes/[DATA-STORE]/[PATCH_FILE].zip

بعد از آپدیت نیاز هست که Host مجدداً از نو راه اندازی بشه (Reboot).

برچسب‌ها: iman mojtahedin yazdi
تاریخ ارسال: سه‌شنبه 12 اسفند‌ماه سال 1393 ساعت 13:59 | نویسنده: Iman Mojtahedin Yazdi 0 نظر

پیکربندی Etherchannel جهت ارتباط سوئیچ و سرور VMWare ESXi



به منظور افزایش سرعت دسترسی به سرور های مجازی میزبانی شده بر روی یک هاست فیزیکی ESXi و افزایش قابلیت اعتماد و امنیت ، بهتر است تا در صورت وجود پورت خالی بر روی سوئیچ، از پیکیربندی Etherchannel بر روی سوئیچ و NIC teaming بر روی هاست ESX استفاده کنید.
 برای این منظور ابتدا بر روی هاست ESX پیکربندی زیر را انجام دهید:

  1. همه پورت های شبکه به جر یکی را در حالت Shutdown قرار دهید.
  2. در منوی vSwitch و Management Portgroup گزینه load balancing را انتخاب و بر روی حالت Route based on ip hash قرار دهید.
  3. پیکربندی port channel بر روی سوئیچ.
  4. فعال سازی مجدد پورت ها بر روی physical switch








حال نوبت پیکربندی سوئیچ متصل به سرور است که به منظور فراهم آوردن امکان Failover می تواند بصورت یک Stack Switch نیز استفاده گردد. هنگامی که شما بخواهید یک لینک Etherchannel را بین دو سوییچ سیسکو برقرار کنید، وضعیت لینک ایجاد شده(mode) را می توانید در یکی از حالت های جدویل ذیل تنظیم نمایید:


Mode
Negotiation
Operation
on
None
Enables EtherChannel, does not negotiate
off
None
Disables EtherChannel
active
LACP
Initiates negotiation to enable EtherChannel
passive
LACP
Responds to received negotiation requests
desirable
PAgP
Initiates negotiation to enable EtherChannel
auto
PAgP
Responds to received negotiation requests

از آنجا که ESXi تنها از Negotiation Mode مدل on پشتیبانی می کند، لذا بر روی سوئیچ متصل به سرور ESXi پیکربندی پورت Etherchannel بصورت زیر خواهد بود:

interface Port-channel 1
 description Link aggregate for “ESX Server"
 switchport trunk encapsulation dot1q
 switchport mode trunk
switchport trunk nonegotiate
!
interface GigabitEthernet 1/1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk nonegotiate
channel-group 1 mode on
!
interface GigabitEthernet 2/1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk nonegotiate
channel-group 1 mode on
!
برای اطمینان از صحت عملکرد اینترفیس ایجاد شده از دستور زیر استفاده می شود :


Switch# show etherchannel load-balance

EtherChannel Load-Balancing Configuration:
src-dst-ip
برای تنظیم متد Load-balance بر روی سوئیچ به نحوی که با تنظیمات این پارامتر بر روی سرور ESXi همسان گردد، دستور زیر را بر روی سوئیچ وارد نمایید :
port-channel load-balance src-dst-ip

تاریخ ارسال: شنبه 7 بهمن‌ماه سال 1391 ساعت 03:50 | نویسنده: Iman Mojtahedin Yazdi 0 نظر
( تعداد کل: 7 )
   1      2   >>
صفحات